Phone Support Outage
Incident Report for Mammoth Cloud
Resolved
Phone services have now been restored.
Posted over 1 year ago. Dec 20, 2016 - 10:10 AEDT
Identified
The Mammoth Cloud phone support system is currently unavailable.

At this time we are unable to provide an estimated time of phone services being restored.
Posted over 1 year ago. Dec 19, 2016 - 10:44 AEDT